Photo: Someone with aptitude in this sort of thing, here's a xmas riddle for you:

Since sometime last week, new posts made on +OMG! Ubuntu! experience a 504 gateway/nginx error after being published.

Posts made before this 'last week' milestone aren't affected, nor is the main site, but all posts made after it will either 504 or throw a 'database connection error'.

The whole schaboodle sorts itself out after 20-40 mins, and will work fine until... the next new post or edit, when it repeats itself.

I should add that following a new post the CPU will spike to 100%, but whether this is because people are 'hitting' the site because they got a 'new post' alert, or whether it's something the site itself is causing on posting, I don't know.

Image via fc01.deviantart.net
Loading...
Joe Sneddon
Public
Someone with aptitude in this sort of thing, here's a xmas riddle for you:

Since sometime last week, new posts made on +OMG! Ubuntu! experience a 504 gateway/nginx error after being published.

Posts made before this 'last week' milestone aren't affected, nor is the main site, but all posts made after it will either 504 or throw a 'database connection error'.

The whole schaboodle sorts itself out after 20-40 mins, and will work fine until... the next new post or edit, when it repeats itself.

I should add that following a new post the CPU will spike to 100%, but whether this is because people are 'hitting' the site because they got a 'new post' alert, or whether it's something the site itself is causing on posting, I don't know.

Image via fc01.deviantart.net

6 plus ones
14 comments