You guys if you are using an I'phone, I'pad, or I'pod Touch paired with a braille display DO NOT UPDATE TO IOS 10.2!!! This newest update caused an I'pad belonging to a girl on my O&M instructor's caseload to forget her braille display. It won't re-pair now. It may cause your apple product to do the same. Apple is usually very conciderate, but sometimes "bug fixes and performance improvements" will dampen voice-over compatibility when written in any update. To be on the safe side, look out when they come out with the next Mac update too.

All blind people here, please never buy a kindle fire! it is not compatible with a braille displays and the "voice-over", if it can be called that, is SCAFFY!!! Even if you can see, don't give them money. I looked at a friend's kindle and it was AWFUL. What divices does your local school district use?

This is such a lonely community

I love this idea

Post has shared content

Post has shared content

Post has shared content

Post has shared content

Post has shared content

Post has shared content
Wait while more posts are being loaded