Profile cover photo
Profile photo
Greg Zimmers
107 followers
107 followers
About
Greg's posts

I am having trouble programming the Alamode. I have completed installation and configuration (resolving some issues others have had). Got the board showing up as well as the port.

My problem: I can't send the simple "blink" sketch. I have tried 115200 baud as well as 57600. Both fail with the same error. Here are my verbose output from both attempts.

Binary sketch size: 1,056 bytes (of a 32,256 byte maximum)
/usr/share/arduino/hardware/tools/avrdude
-C/usr/share/arduino/hardware/tools/avrdude.conf -v -v -v -v
-patmega328p -calamode -P/dev/ttyS0 -b115200 -D
-Uflash:w:/tmp/build18792512809611433.tmp/Blink.cpp.hex:i

avrdude: Version 5.11svn-20111019, compiled on Feb 15 2015 at 18:22:47
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is
"/usr/share/arduino/hardware/tools/avrdude.conf"
User configuration file is "/home/pi/.avrduderc"
User configuration file does not exist or is not a regular
file, skipping

Using Port : /dev/ttyS0
Using Programmer : alamode
Overriding Baud Rate : 115200
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

And then at 57600 baud attempt result

Binary sketch size: 1,056 bytes (of a 32,256 byte maximum)
/usr/share/arduino/hardware/tools/avrdude
-C/usr/share/arduino/hardware/tools/avrdude.conf -v -v -v -v
-patmega328p -calamode -P/dev/ttyS0 -b57600 -D
-Uflash:w:/tmp/build3446814886307353351.tmp/Blink.cpp.hex:i

avrdude: Version 5.11svn-20111019, compiled on Feb 15 2015 at 18:22:47
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is
"/usr/share/arduino/hardware/tools/avrdude.conf"
User configuration file is "/home/pi/.avrduderc"
User configuration file does not exist or is not a regular
file, skipping

Using Port : /dev/ttyS0
Using Programmer : alamode
Overriding Baud Rate : 57600
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

I am out of ideas. Anyone have any ideas of what to try next?

Thanks!

Post has attachment
Focus the camera!


Post has attachment

Post has attachment

Post has attachment

Post has attachment
Photo

Post has attachment
Wait while more posts are being loaded