The wholoe "LIGHTREAD DOESNT EVEN USE LINUX DEVELEMPENT STUFF!!111" argument reminds me of:

"I'm not using that app - it's written in Qt"
and
"I'm not using that app - it uses mono"
etc

Who cares what it uses as long as it gets the job done, and done well. 
Shared publiclyView activity