Profile

Cover photo
Anthony Roby
9 followers|2,026 views
AboutPostsPhotosVideos

Stream

 
I'm playing around with various things connected to each other using XBee Zigbee modules.  Right now, Zigbee isn't supported, so I was contemplating building a simple gateway controller, through which I can connect to the things.  Is that something that is supported?  I couldn't see anything obvious in git to use as a starting point. 

An example thing would be a garage door controller which also holds the state of the door.  I have 3 of these, so I think I would need some kind of IP to Zigbee gateway to control them from the #steward - it would think it's talking to IP devices, but really would be talking to Zigbee things.

Any suggestions of starting points?

Anthony
1
Ivo Nijenhuis's profile photoMarshall Rose's profile photoAnthony Roby's profile photo
6 comments
 
take a look at the greenwave gw110 (a.k.a. nuon emanager). it's a z-wave and zigbee ip gateway kind of like the greenwave gop I'm trying to figure out how to hack in to it. but I'm kind of new to this.
Add a comment...
 
How do you rename a device?  I have a Z-stick and a GE Z-wave power outlet. The #steward had no problem finding them, but I'd like to override the name (device/3) that is chose.

Also, for these binary devices wouldn't it be better when you click "turn on" in the d3 UI for it just to turn on, rather than display a popup to turn on?

Nice work overall.  Now I just need to learn node.js to figure out how I can get to grips with everything!
1
Jason DeVelvis's profile photoDaniel O'Connor's profile photoAnthony Roby's profile photo
14 comments
 
+Daniel O'Connor I'm just going to reflash my installation tonight and use Chrome to rename my device - far easier than messing with all this node.js stuff that doesn't seem to work!
Add a comment...
Have him in circles
9 people
Sean Leahy's profile photo
Jim Stogdill's profile photo

Anthony Roby

The Steward  - 
 
Just fired up release 1.5. I only have a small test system - 1 pi, a Z-stick A2 and a GE Z-wave socket.  It worked fine with 1.4.  On 1.5, when I try to turn on the socket, I get

unknown api: /api/v1/device/perform/3

Any ideas?

Anthony
1
Alasdair Allan's profile photo
 
Not immediately sure what's going on. Could you open a ticket on the issue tracker, https://github.com/thethingsystem/steward/issues, with some more details?
Add a comment...

Anthony Roby

Shared publicly  - 
 
Just joined Google+ in order to register for the Google IO event at the end of June.
1
Add a comment...
People
Have him in circles
9 people
Sean Leahy's profile photo
Jim Stogdill's profile photo
Links
Basic Information
Gender
Male