Looks like "support" for TestNG 6.x has landed in IntelliJ IDEA. I say support because it looks like the plugin now just warns your project uses a newer, incompatible version of TestNG, then falls back to the older, bundled version giving the user a balloon error message.

Not quite the solution either +Cedric Beust or myself would rather see, what would be nice here is if the balloon error message gave the user the option of using the bundled version OR the project version.

Still, if this prevents IDEA from giving the socket error it currently gets, it's a suitable stop-gap measure for the upcoming 11.1 release before something better can be worked out.
Shared publiclyView activity