Cinnamon 1.8 is now available to in the Romeo repository
Unstable and Unsupported. 

http://segfault.linuxmint.com/2013/05/cinnamon-1-8-in-romeo/
Just check the box and apt-get update
sudo apt-get upgrade cinnamon*
3
1
Tim Lawless's profile photoAaron Kellar's profile photoRobert Allen's profile photo
4 comments
 
yeah its pretty stable. It is only in romeo because they don't intend to provide support for it.
 
You should hear the assholes in the Mint IRC channel. They will kick you out the channel for talking about unsupported software.
 
It will go to backports after 15 is released I've never seen anyone kicked for asking for any support in irc I'm there all the time 
Add a comment...