Can someone tell me why the Nexus 7 (2012) is no longer on the supported list for Google Wallet since the 2.0 update? It comes preinstalled with wallet and has the proper NFC capability to do it. I don't understand this

Edit:

Found out how to fix this (well to get the latest version installed anyway, still have it saying it isn't compatible with this version in the Play Store), see below
Photo
Shared publiclyView activity