Profile cover photo
Profile photo
Shn Naser
61 followers
61 followers
About
Posts

Post has attachment

Post has attachment

Mr. Kilmer I need your help.

My 2006 Mercedes E350 Base Model was making poping sounds from the rear wheels when putting it into drive after a while of being turned off.

A couple of days later I was behind a red light and felt like someone hit me. It was my transmission.

I got an error on the dash that said something like ESP Malfunction.

Later I got a second warning saying ABS Malfunction following the ESP Malfunction.

The car will not shift out of first gear and slams into gear when punt into drive. Reverse seems better, but I had it towed to a repair shop.

The problem is that I was told it must be the wheel speed sensor, but it seems the guy at the shop said it is slamming so hard it may be the transmission.

The SBC brake unit and the ABS pump including the AUX battery were all changed recently.

What could have gone wrong?

Could I have done something wrong?

Was there some way I could have prevented this problem?

What should I do?

Post has attachment

Post has attachment

Post has attachment
Add a comment...

Post has attachment

Post has attachment

My this guy sent me this link to get a $5 coupon at Amazon for signing into the Amazon App the first time.

Check it out. It was legit. It is only a 5 dollar credit, but better than nothing.

https://amazon.com/mpr?referralcode=N1287N&ref_=mpr_tr_ss
Add a comment...

Post has attachment
Awesome Sushi!
Add a comment...
Wait while more posts are being loaded