Profile cover photo
Profile photo
Draino's Networking and Technology
41 followers -
A techno-geek's no how and information for the masses
A techno-geek's no how and information for the masses

41 followers
About
Draino's Networking and Technology's posts

I got hit with what appears to be a fairly ubiquitous bug of debian/libvirt.

Lucky for me another user already posted not only the trivial fix, but also how they identified the root cause.

Details can be found here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=757952

#debian   #linux   #virtualization  

Post has attachment
Upon arriving back home from a three-week holiday, I took the opportunity to perform some trivial maintenance on my KVM server whilst I had it powered down, which included:

- Installation of a 4-port Intel-based Gigabit NIC
- Change from a 4-core to an 8-core CPU

Since both PC and server have very similar motherboards, I simply took the 8-core CPU from the windows box and swapped that with the 4-core CPU from the server (luckily) with no WPA trigger on the desktop.

I was hoping to replace the PCI-based VGA graphics card so that I can interact with the GUI-based EUFI BIOS, but I didn't realise that the card I had acquired is low-profile.

Now the KVM server should be able to handle more VM provisioning and I can continue and maybe one day complete the Guide to SysAdmin-ing

http://sirlagz.power.on.net/guide-to-linux-sysadmin-ing/

#linux   #server   #maintenance   #sysadmin  

Post has attachment

Spent a good couple hours testing and failing to get a bind9 reverse lookup zone to load only to find out that I had a slight typo in the reverse lookup zone definition.

One thing I have learned is:

- Always check your config with the bind dns tools
- Always check your zones files with the bind DNS tools.

Now that I have the dev domain DNS working, I just need to look at possibly moving resource record types into different separate files as well as testing dynamic DNS.

Post has attachment

Post has shared content
At $49USD this is a bargain and a worthwhile investment at that
If you believe in Linux and the open source movement, consider becoming an individual member of The Linux Foundation. Between now and August 8th, you can also get a certification exam for just $49! More information here:

http://www.linuxfoundation.org/news-media/announcements/2015/07/linux-foundation-s-individual-membership-drive-help-it
Photo

Post has shared content
The things I do in my spare time...

I'm also getting exceedingly good and setup and reverting the configuration.

#linux   #networking   #paspberrypi

Post has attachment

root@kvmhost:~# free -gho
             total       used       free     shared    buffers     cached
Mem:           31G       1.7G        29G         0B        26M        88M
Swap:          14G         0B        14G
Photo

Post has attachment
In order to get the routing and NAT functionality that is so lacking in my current Netgear DGND4000 (doesn't route/NAT anything other than it's own resident subnet!), I have purchased a +Raspberry Pi 2 and I am in the process of configuring OpenWRT to provide said functionality.

Unfortunately, at the time of writing this OpenWRT does not have a "stable" release and I currently using the built image provided over at the the following page:

http://dab-embedded.com/en/blogs/openwrt-on-arm-based-platform-raspberry-pi-2/

I am currently tweaking the official OpenWRT trunk/snapshot (RC1) so as to expand/make use of the whole microSD card, but so far I have managed to get functional VLAN's as per the below configurations:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option proto 'static'
        option ip6assign '60'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option ifname 'eth0.333'
        option ipaddr '192.168.3.6'
        option netmask '255.255.255.248'
        option gateway '192.168.3.1'

config globals 'globals'
        option ula_prefix 'fd20:6d59:d3e9::/48'

config interface 'wan'
        option ifname 'eth0.666'
        option _orig_ifname 'eth0.666'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username '***'
        option password '********************'


Partial CISCO 3650 running/startup config:

vlan 333
 name DMZ/LAN
!
vlan 666
 name DMZ/WAN
!
interface GigabitEthernet0/14
 switchport access vlan 666
!
interface GigabitEthernet0/15
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 333,666
 switchport mode trunk
!
interface Vlan333
 ip address 192.168.3.1 255.255.255.248
!
interface Vlan666
 ip address 192.168.0.1 255.255.255.248
!

The above was enough to get VLAN tagging working, however I am going to do further testing by reverting the LAN interface so the only vlan tagging that is performed is on the pppoe-wan interface.

One of the only hiccup I encountered was that I have to momentarily switch the SSH (dropbear) instance under System > Administration to the WAN interface, saved and then changed back to the LAN interface and saved again in order to allow SSH into the device.


#rasberrypi   #linux   #openwrt
Photo

Managing networking on a multi-homed server with partial bonded/etherchannel links is proving to be quite a challenge.

Also, I am getting much, much closer to deploying OpenStack (PackStack) on this same host, however this is dependent on:

1) More disk space in order to backup existing data
2) More memory in order to run more instances (including virtual network components).
3) Temporary router that can NAT/route all subnets other than it's resident subnet to maintain internet connectivity whilst installing OpenStack.

Fun times ahead.

#linux   #networking   #openstack   #sysadmin  
Wait while more posts are being loaded