Profile cover photo
Profile photo
Gábor Menyhért
2 followers
2 followers
About
Posts


Proposal: Every function should have zero or one parameter.
Multiple arguments can be passed by wrapping them in an object.
This restriction will make programs more extensible and easier to read.
old way: draw_rect(0, 0, 50, 50)
new way: draw_rect({ x: 0, y: 0, width: 50, height: 50 })
In my opninion the old way is almost as cryptic as assembly language.
Wait while more posts are being loaded