Profile cover photo
Profile photo
Miguel Borges
146 followers
146 followers
About
Posts

Post has attachment
Add a comment...

eu estou a fazer um trabalho universitário de engenharia de software em laravel.

Neste momento estou com uma dúvida. O sistema final irá ser composto por dois subsistemas: webapp e outro. A webapp irá ficar responsável por guardar todos os dados, à excepção de um recurso, que terá de obte-lo através de um webservice rest.

Por exemplo, um cliente tem/faz vários contractos. Neste caso os clientes estão guardados na BD local e os contratos  são para ser guardados no outro sistema através do webservice. A minha dúvida é saber qual a melhor maneira de construir a camada de acesso aos dados.

Tinha pensado em implementar o padrão repositório, mas não sei se é a melhor solução, pois tenho uma relação de um para muitos entre os modelos.

Post has attachment
Add a comment...

Post has attachment

Post has attachment
Mavideo telemóveis
Mavideo telemóveis
miguelborges.com
Add a comment...

Post has attachment

boas pessoal.
estou a desenvolver uma aplicação em L4.
já está quase pronta e queria-a por no servidor final.
a app vai ficar num subdominio tipo ap.meusite.com. o site principal e o dominio estão num shared host e a app nao vai funcionar lá.
estou a pensar em coloca-la na Digital Ocean o meu problema é que não sei como coloco o subdominio a apontar para lá.

jagora, alguem sabe de um tutorial em PT de deploy de aplicações laravel com git?

Post has attachment
boas, desenvolvi uma app em laravel e agora preciso de host. nao posso usar um compartilhado porque usei algumas bibliotecas nao usuais.
para alguem de um servidor web (apache, php, mysql, phpmyadmin) necessito também de um servidor de emails, para criar email com o dominio, bem com alguma interface grafica, para os gerir (como cpanel). Para isto aconselharam-me a usar o VestaCP (http://www.vestacp.com/) na DO, mas estou com uma dúvida:  na gestão do meu domínio o k coloco nos Nameservers?

Post has attachment
Add a comment...

ao correr o composer update está a dar um erro de incompatibilidades com o entrust e o ardent.

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - zizaco/entrust dev-master requires laravelbook/ardent ~2.4 -> no matching package found.
    - zizaco/entrust dev-master requires laravelbook/ardent ~2.4 -> no matching package found.
    - Installation request for zizaco/entrust dev-master -> satisfiable by zizaco/entrust[dev-master].



"require": {
        "laravel/framework": "4.2.*",
        "teepluss/theme": "dev-master",
        "zizaco/confide": "3.2.x",
        "zizaco/entrust": "dev-master",
        "laravelbook/ardent": "dev-master",
        "edvinaskrucas/notification": "2.*",
        "thomaswelton/laravel-gravatar": "dev-master"
},
Wait while more posts are being loaded