Polymer Code Lab - dia 19 - das 14h às 15h30
Softwares necessários (ambiente de desenvolvimento)

A instalação prévia dos seguintes softwares é necessária.
Caso você encontre dificuldades para instalar os softwares, faça o download dos mesmos e chegue ao Code Lab com 20 minutos de antecedência, para que possamos ajuda-lo(a) com as instalações.


Python 2.7.x (ultima versão do Python 2.7)
Atenção: Estamos solicitando a instalação do Python apenas por segurança, como uma segunda alternativa de servidor HTTP. Não é necessário conhecer ou saber usar o Python.
http://www.python.org/getit/
Python 2.7.5 Windows X86-64 Installer (Windows 7 e 8 64-bit)
Python 2.7.5 Windows Installer (Windows 7 e 8 32-bit)
Nota: Máquinas Linux ou Mac já vêm com o Python instalado.


NodeJS (Ultima versão - 0.10.21)
Atenção: A instalação do NodeJS é necessária apenas para o bom entendimento do ambiente de desenvolvimento e agilizar a execução do code lab. Não é necessário conhecer ou saber usar o NodeJS. Utilizaremos apenas alguns comandos do NPM (Node Packaged Modules).
http://nodejs.org/download/
----------------
W7 e W8: Windows Installer (.msi) 32-bit ou 64-bit
-----------------
Mac: Mac OS X Installer (.pkg)
------------------
Linux - Faça a instalação do NodeJS através do gerenciador de pacotes da sua distribuição.


Git (ultima versão - 1.8.4)
Atenção: A instalação do Git é necessária apenas para o funcionamento adequado do gerenciador de pacotes do NodeJS. Não é necessário conhece-lo ou saber usar-lo.
----------------
msysgit (Windows )
https://code.google.com/p/msysgit/downloads/list?q=full+installer+official+git
-----------------
Mac (from official website)
http://git-scm.com/download/mac
------------------
Linux: Faça a instalação usando o gerenciador de pacotes da distrubuição que você usa.


A ultima versão do seu navegador preferido.
Nota 1: Optei por usar o Chrome Canary na elaboração e apresentação do CodeLab.
---------------------
Nota 2: Navegadores suportados (Lista criada em 09 de Novembro de 2013):
Chrome Canary
Chrome
Firefox
Safari 6+
IE 10+ (Existem algumas limitações)
----------------------
Nota 3: Tabela atualizada de compatibilidade dos navegadores: http://www.polymer-project.org/compatibility.html
Shared publicly