Profile cover photo
Profile photo
Vasily Alexeev
39 followers
39 followers
About
Vasily's posts

Давно тут не был. Ну раз уж зашёл, так "поделюсь чем-нибудь", как мне предлагает гугл.

Итак, делюсь: недавно запустили сайт teslalc.ru. Мне нравится.

Post has attachment

"RubyGems 1.3.7 or higher is required with following limitations :
Rails 2.3.5 will fail with RubyGems 1.5.0 or later, stick to previous versions of RubyGems !

Rails 2.3.11 will fail with RubyGems 1.7.0 or later, stick to previous versions of RubyGems !" (из инструкции по установке Redmine)

Я вот не понимаю. Казалось бы, в Ruby есть ровно 3 компонента которые нужны всем:
1) Ruby
2) RubyGems
3) Rails

Почему работает ровно одно сочетание их версий? Почему между 2.3.5 и 2.3.11 вообще есть какая-то разница? Я всегда думал, что третье число в версии - для мелких багфиксов. В среде разработчиков руби принято что ли между любыми двумя версиями полностью менять API? Почему Django спокойно работает на Питоне от 2.4 до 2.7? Почему Джанге вообще всё равно, стоит ли pip или easy_install или я его через apt-get поставил?

Post has shared content
Рекомендую почитать каменты от Uriel Étranger к этому посту:
Why do Python classes have both _mro_ and mro() ? What was I thinking at the time? Does anyone remember?

Post has attachment
Кстати, вот и обещанное API для Яндекс.Почты для домена: http://v-alexeev.ru/?p=9

У меня в последнее время складывается всё более стойкое впечатление, что работников в Яндекс набирают исключительно по блату, и то по принципу "чем меньше знаешь - тем лучше". Иначе чем объяснить например то, что всех, кто пытался туда устроиться, про кого я слышал и у кого не было блата, туда не взяли, но при этом у них появляются API для Питона написанные так как вот тут: https://pdd.yandex.ru/help/section72/ (я не выдержал, и этот API переписал)

я бы ещё кое-что на тему написал, но не буду.

Post has shared content
Вот бы ещё Джангу под питон 3 переделали.

Post has shared content

Блин. Спасибо, гуглоплюс, за "Популярное" с кошечками и ржакой. Как раз этого мне тут и не хватало.

Post has attachment
В iPhone 4S внезапно заявлена поддержка ГЛОНАСС.

(Location: Assisted GPS and GLONASS)
Wait while more posts are being loaded