Profile cover photo
Profile photo
Janne Liljeblad
17 followers
17 followers
About
Posts

Post has attachment
Flatpak for Flowblade 1.16 is now available from Flathub, thanks for update by eszlari!

I added instructions on how to install Flatpak:
https://github.com/jliljebl/flowblade/blob/master/flowblade-trunk/docs/INSTALLING.md#installing-flatpak-from-flathub
flowblade
flowblade
github.com

Post has attachment
Flowblade 1.16 is now out!

Release notes: ttps://github.com/jliljebl/flowblade/blob/master/flowblade-trunk/docs/RELEASE_NOTES.md

Installing: https://github.com/jliljebl/flowblade/blob/master/flowblade-trunk/docs/INSTALLING.md

We are a month late on target, but in the software world that ain't much.

This wasn't new feature wise a massively productive cycle, but we are also now in a place with the app where each new feature will get looked at more critically before inclusion, and stability, performance and limited dependencies are more and more central considerations.

We will keep the two releases a year release rhythm, but will not give any release dates, it's more "when it is done" from now on.

flowblade
flowblade
github.com

Post has attachment
Flowblade 1.14 is out now, yeah.

Release notes: https://github.com/jliljebl/flowblade/blob/master/flowblade-trunk/docs/RELEASE_NOTES.md

Installation: https://github.com/jliljebl/flowblade/blob/master/flowblade-trunk/docs/INSTALLING.md

Overall I'm very happy with the release, we got many new features in.

A lot of new code means that some loose ends will probably need to be picked up further down the line, but release testing did get a good set of bugs fixed that could have been overlooked, so I'm optimistic that we are still in good shape stability wise.

To add a bit on the release notes, one of the guide lines moving forward is that we will not make the learning curve for beginner users any steeper, instead we will take every opportunity to lower it a bit and there already are some ideas towards this goal.

The Wayland capability is also been worked on, but no results yet, the work continues.

Happy editing with the new release.
flowblade
flowblade
github.com

Hi, I've been on vacation for a few days and will be for a week still, i'll comment here more after that, right now just enjoying sun etc.

Post has attachment
There was a problem with the first 1.12 release, the "Volume" filter stopped working.

If you installed 1.12 from package offered prior to this message appearing, uninstall Flowblade and go get the updated .deb package. I didn't update version number, but the new working .deb is now uploaded in :


https://github.com/jliljebl/flowblade/releases
flowblade
flowblade
github.com

Post has attachment
Flowblade 1.12 is out now! This cycle might not have been such a smash success as the last one because some objectives were not met but on the other hand we got more contributions than ever.

Main new feature is the Box tool, shown in action here: https://vimeo.com/207310517

Next release is coming in August, it seemed better to move to 2 releases per year rhythm, even more so because we need to devote some development time on continuing working on container packages.

Hopefully release is bug free and the new features and bug fixes continue to improve user experience for everyone.

Release notes: https://github.com/jliljebl/flowblade/blob/master/flowblade-trunk/docs/RELEASE_NOTES.md

Installing: https://github.com/jliljebl/flowblade/blob/master/flowblade-trunk/docs/INSTALLING.md
flowblade
flowblade
github.com

Ok, there will be no AppImage for 1.12, it just does not seems to come together. It would be possible to create an AppImage with MLT 0.9.0, but that's too old to distribute.

My attempts at combining MLT 6.4.1 with other binaries have failed and I'm going to give up for now.

This means that AppImage or any other binary package will come earliest for 1.14.

Creating binary packages is basically the same thing as being a distro developer, not an activity I have much skills or interest in, so any contributions in this area will be greatly appreciated.

I burned a lot of time working on this, but now I will no focus on getting 1.12 ready with the usual .deb package provided.

January I closing and we have the next release feature set taking shape.

- New "Trim Ripple Tool" is mostly done with some small fixes still needed. This allows trimming clips without losing sync between tracks in the timeline after trimmed cut.

- AVFilters are being integrated. The most useful addition is the "Zoom Pan" filter that will replace the current "Affine" filter which rarely works for zooming.

- Work on packaging with Appimage and Snap is yet to be started, but at least Appimage will be included for next release.

- Development on new "Overwrite Box" tool is just starting, and this will be in next release if everything goes well. This will allow for moving clips from multiple tracks as a single unit, a feature that has been frequently asked for.

- The last 2-3 weeks of this cycle will be spend on Issues list

Everything is so far looking quite good for release of 1.12 in the first half of March.

Post has attachment
The 1.10 release in now out, release notes here: https://github.com/jliljebl/flowblade/blob/master/flowblade-trunk/docs/RELEASE_NOTES.md

Installing instructions here: https://github.com/jliljebl/flowblade/blob/master/flowblade-trunk/docs/INSTALLING.md

I think the release was big step forward, and the Trim View functionality will be greatly appreciated by the users. Hopefully all the bugs are squashed.

With a bit more push it could have been possible to get the release out a bit earlier, but as usual year's end is a time when development slows down and writing even the release notes seems like something one feels can done tomorrow or maybe next week. There probably will not be much activity for the rest of the year, and new developments will start happening in first weeks of January.

Merry Christmas to everyone, and I'll post more info when new stuff starts taking shape.

flowblade
flowblade
github.com

Please install hotfix release MLT 6.4.1. if you are having trouble starting Flowblade with recent versions of MLT.

6.4.1 fixed the issue with print out ERROR: /usr/lib/python2.7/dist-packages/mlt.x86_64-linux-gnu.so: undefined symbol: ZNK3Mlt7Profile8is_validEv

* MLT 6.4.0 is indeed broken for Python bindings and Flowblade
* I thought that the issue was with mismatching installed versions of MLT, but I was wrong and that was not the case
* adding new methods should not break the bindings but unfortunately there was just one "const" missing from where it was needed. This has now been fixed.
* the breaking commit was done on July 21, so MLT is broken for Flowblade from that point until 6.4.1

Please inform your OS maintainer to upgrade MLT to 6.4.1 to fix this if you are having this issue.

This is the kind of stuff that unfortunately sometimes happens, but MLT made a quick bugfix release and everything should be OK again.

I made the mistake of assuming a bit too much here, this exact type of issue has come up many times on my development system when different versions of MLT have been installed, but this time this was not the cause, and this has certainly caused some unneeded difficulties for users of Flowblade.
Wait while more posts are being loaded