What's the proposed upgrade path if you did not update #portage  in a #hardened  profile a long time? There is no way of reverting back because the profiles are not versioned in hardened...

# emerge -1a portage
!!! Unable to parse profile: '/etc/make.profile'
!!! ParseError: Profile contains unsupported EAPI '5': '/usr/portage/profiles/eapi-5-files/eapi'
!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.
Shared publiclyView activity