For those worried about the Heartbleed vulnerability, there is a handy Chrome extension that tests the OpenSSL version of the site you're visiting to determine whether there may be an issue.

https://chrome.google.com/webstore/detail/chromebleed/eeoekjnjgppnaegdjbcafdggilajhpic
Shared publiclyView activity