Shared publicly  - 
 
Grrr at my Galaxy S2 .. Won't recognize Any sim card .. >:(
2
Kyle shirto's profile photoTornike Bardavelidze's profile photokukuh aji's profile photoDamien Cole's profile photo
94 comments
 
well babe we are going to have to find if someone can fix it then for you
 
maybe depends if u can find someone first
 
phone finally fixed.
seems my efs system was corrupt?? .. no imei or baseband displayed for the phone but i still had mac addresses for the bluetooth and wifi ..

efs system also contains unlock codes for the phone so if you cant unlock it / forgot you pin / pattern you can reflash the efs (make backups prior is recommended .. go on .. do it now :P)

I had to use a friends gs2 to fix and obtain a backup of the efs system. Both phones are rooted w/ Superuser:

1. install ktool.apk on your phone and friends phone
2. backup friends working phone efs using ktool (efs.img)
3. copy file to your pc then phone root (normal internal sd) .. you could also email the file .. it is around 20mb in size.
4. use ktool to reflash (restore) friends efs.img to your phone
Bam! working again!!

Phone now unfortunately has a generic imei though but is totally usable again :D
 
Hello, I'm having the same issue. Can you send me a backup efs to restore it?
 
No worries, my .bak files were corrupt too
 
I'm having the exact same problem, and no backup, any chance you would send me your backup efs?
 
my phones been out of commission for 3 days now, finally it works, thanks SO much
Translate
 
Hi +Damien Cole I am having exactly same problem, but my phone is not rooted. Can I use the same efs file you uploaded to fix my phone or i have to find efs file from a handset that is not rooted? Thx.
 
hi +Damien Cole, is the file still available on the server? I'm having problem downloading it
 
Hi Damien,
I am trying to help a friend with his SGS2 that EFS folder has been deleted.
Could you please upload again your EFS file? I cannot access it for some reason
Thanks
 
Thaks!! downloaded it.
Will try tomorrow, hope it will work.
BTW, what does it actually mean having a generic IMEI? pors? cons?
 
Apparently the machine fell into water (I was not told...) and there was a HW issue. 
SGS2 IMEI and falling into water have a reputation of causing serious problems I found out in several shops.
 
Yeah, The solution I had was for a software issue
 
hi! i've done everything but my s2 hasn't any imei and sim doesn't work...please help me! i'm desperated...!
 
Hi, Damien. I followed your instructions and using the kTool and extracted my phone's 2 files. Copied them to the broken phone and both the efs.img and efs.tar.gz files were found, but underneath the 2 lines reads: /!\ nv_data.bin NOT FOUND in backup!!!

I've been researching the solution for hours since yesterday. Bought my mum a used S2, flashed a ROM and... boo! Everything works except no network connection.

Any help on this is appreciated. Thanks.
 
Is your original s2 "rooted" i.e. you have an unsecure kernel flashed?
 
Ah, thanks for replying so quickly. Your original post was from 2011, I
realized that after I summited my comment.

Anyway, yes, definitely rooted but nor sure which kernel ( actually I don't
even know what kernels are) and flashed the CM10 ROM. Sigh! I'm about to
give up. So close but feels like a million miles away... The IMEI is intact
on the phone though.

Thanks again, Damien.

Robert
<https://plus.google.com/_/notifications/emlink?emr=09082949576147827306&emid=CMiFybO1mbUCFW0FTAod_TkAAA&path=%2F107335959710263043900&dt=1359869700624&ub=7>
Is your original s2 "rooted" i.e. you have an unsecure kernel flashed?
Reply to this email to comment publicly on Google+. Or view Damien Cole's
post »<https://plus.google.com/_/notifications/emlink?emr=09082949576147827306&emid=CMiFybO1mbUCFW0FTAod_TkAAA&path=%2F107335959710263043900%2Fposts%2FJHwvK3T1aPu&dt=1359869700624&ub=7>
Damien Cole<https://plus.google.com/_/notifications/emlink?emr=09082949576147827306&emid=CMiFybO1mbUCFW0FTAod_TkAAA&path=%2F107335959710263043900&dt=1359869700624&ub=7>commented
on Damien
Cole<https://plus.google.com/_/notifications/emlink?emr=09082949576147827306&emid=CMiFybO1mbUCFW0FTAod_TkAAA&path=%2F107335959710263043900&dt=1359869700624&ub=7>'s
post. Mute Damien
Cole<https://plus.google.com/_/notifications/emlink?emr=09082949576147827306&emid=CMiFybO1mbUCFW0FTAod_TkAAA&path=%2F107335959710263043900%2Fop%2Fmute&dt=1359869700624&ub=7>to
stop receiving notifications from him.
Mute<https://plus.google.com/_/notifications/emlink?emr=09082949576147827306&emid=CMiFybO1mbUCFW0FTAod_TkAAA&path=%2Fnotifications%2Fall%2Fz120whq5nlbrflwxx04ccf2hrmf5xhljohg%3Fmute%3Dz12uhnna3yrushgfb222snhwmtjfgfx3f&dt=1359869700624&ub=7>updates
to this post.
Change<https://plus.google.com/_/notifications/emlink?emr=09082949576147827306&emid=CMiFybO1mbUCFW0FTAod_TkAAA&path=%2Fsettings%2Fplus&dt=1359869700624&ub=7>what
email Google+ sends you.
Privacy tip: Protect your info. Remove your email signature before you
reply.
Google Inc., 1600 Amphitheatre Pkwy, Mountain View,
 
Oy. I replied via Gmail and looked what happened. My apologies.
 
Hi Damien, i have a S2 (rooted) and my current IMEI is null. I did the steps you told but its not working:
1. Deleted all the content in my efs folder
2. Downloaded kTool
3. Restore your efs folder

It says that all was ok, and need to reboot. I rebooted but still have imei in blank. Can you help me?

Thanks!
 
It may be the actual rom you are trying to install. Try another rom first and see if your imei is restored. Most roms will backup your original imei now too so you may have that in your sdcard (internal) 
 
Backed up imei's are usually made from clockwork recovery roms not Odin 
 
hey Damien, i used your friends efs file that you put up for download, now my password doesn't work. Could it have changed to your friends? If so, could you let me know what it is so i can log back in please! Cheers
 
no.. password was not enabled in efs file. From memory if u enter ur password wrong a few times there is a link or something for forgot password. enter your Gmail account details and it should get u back in
 
Hey Damien, thanks for the help. I have amazed myself by getting my phone to work again, though it did take me around 10 hours of experimenting.

My first problem was that my IMEI dissapeared. This apparently is due to a corruption of the EFS file. Usually this occurs when people are rooting their phones and doing the whole rom flashing business, but for me it was just totally random, I had no interest in all that other stuff.

I used the Ktool like you mentioned and downloaded the EFS file you provided. However, before i used your EFS file i made sure to back up my own using k tool, just in case. Your file semi fixed my problem. It gave me an IMEI number, but it was a generic one. It allowed my data services to work (non-wifi) but wouldn't allow making or receiving of calls.

Eventually after trying all sorts of other rooting methods i simply used K tool and used my own EFS file that i had backed up previously, but instead if the .IMG (which i tried and it didn't help) i restored via the .TAR file. For some reason that worked!

Thanks for the help, i was just about to give up
 
Hopefully your experience will help someone else out. Sounds like your carrier blocks the generic IMEI! 
 
yo, flashed the efs image you uploaded to your server!  
rebooting now :D  
hope this works! i want to poke my eyes out 
 
restored EFS but IMEI still says null/null.  
hardware problem then?  
 
or an original samsung rom via odin
 
flashing an ICS rom.
either way, im leaning towards hardware error. one of the pins or something
moved when it hit something and i didnt notice til i tried to make a call
etc...

your EFS image shouldve at least given me an IMEI right? Still got
null/null

if this doesnt work, im trying a vanilla samsung rom via odin. it'll be my
last attempt before taking it to my carrier and asking for a fix.
will keep this updated!
 
yeah it should of gave you a generic imei.. i know i had problems with certain roms even when my imei wasn't corrupt. suggested an ics rom as that is what i had when i used thw above method. if you have to take ur phone in for repair reflash a backed up original imei and use chainfires triangle away to reset the flash counter
 
ok so now ive got an IMEI but my calls wont go through!
Service State: out of service.
Mobile Network State: disconnected

what does it mean if i have an IMEI but no network?


On Mon, Apr 8, 2013 at 5:48 PM, kloster G <****@**> wrote:

> flashing an ICS rom.
> either way, im leaning towards hardware error. one of the pins or
> something moved when it hit something and i didnt notice til i tried to
> make a call etc...
>
> your EFS image shouldve at least given me an IMEI right? Still got
> null/null
>
> if this doesnt work, im trying a vanilla samsung rom via odin. it'll be my
> last attempt before taking it to my carrier and asking for a fix.
> will keep this updated!
>
>
 
maybe the generic imei is blocked by your service provider? try maybe the method Daniel Christie suggested above.. 
 
followed Daniel Christie's method and ended up the same.
To recap:

1. First and foremost I tested my SIM card with another phone, it worked,
so my SIM card IS NOT the issue.
2. No IMEI, no network service.
3. Flash the efs you uploaded(thanks so much btw).
4. Still no IMEI
5. Flash into ICS rom(sensation 4, but i dont think it matters).
6. Now I have a generic IMEI but still no network service.

last question:
do you know if theres any way I can rule out hardware error?
If I try another SIM card, it should work right? (work as in, access to
network[calls, g3])
 
if the other sim provider doesnt block the generic imei it should work. did u try restoring a backup of ur original imei (efs) 
 
Just checking this is for a galaxy s2, right? 
 
yep Galaxy S2.
I'm reflashing up from ICS since I don't think itll affect my situation.
I'll be trying my friends SIM card later on!
Until then -> got (generic) IMEI and NO service.
 
Only thing I can think of to rule out the hardware issue would be to
generate my IMEI (as far as I know the number I need to generate my own
IMEI is in my battery pack).
however, I don't know how to do that and even if i did I wouldnt know how
to flash it.
Will look that up later on. very tired and frustrated with this at the
moment :D


On Mon, Apr 8, 2013 at 6:34 PM, kloster G <****@**> wrote:

> yep Galaxy S2.
> I'm reflashing up from ICS since I don't think itll affect my situation.
> I'll be trying my friends SIM card later on!
> Until then -> got (generic) IMEI and NO service.
>
>
 
when u flash custom roms usually they backup your original imei/efs.. do u have that file? 
 
try restoring the tar file with ktool
 
Did that and still no go D:

Im looking up how to recreate my own IMEI, if thats even possible.
 
But at least now I dont think it's a hardware problem which means I dont
have to give it to my carrier for a month while they fix it :p


On Mon, Apr 8, 2013 at 7:12 PM, kloster G <****@**> wrote:

> Did that and still no go D:
>
> Im looking up how to recreate my own IMEI, if thats even possible.
>
>
 
Basically i want to change my IMEI number to my original one and not have
the generic one.
Lots of ppl on google saying changing IMEI is illegal so they wont provide
further info...

Still looking though!


On Mon, Apr 8, 2013 at 7:13 PM, kloster G <****@**> wrote:

> But at least now I dont think it's a hardware problem which means I dont
> have to give it to my carrier for a month while they fix it :p
>
>
> On Mon, Apr 8, 2013 at 7:12 PM, kloster G <****@**> wrote:
>
>> Did that and still no go D:
>>
>> Im looking up how to recreate my own IMEI, if thats even possible.
>>
>>
 
yeah it is illegal in certain countries and u need a special kit called a jtag riffbox
 
when you restored the efs from the tar file what was your imei? 
 
Im pretty sure when I restored efs from tar the IMEI didn't change.
So I restored an EFS with the dummy IMEI (my guess is the one you
uploaded).

youre hoping i have a previous backup from when i installed a ROM or
something like that right? since they do autobackups now a days.
I dont think i have a backup unfortunately.

I think ill have to go to my carrier so they can change that.
 
yeah hoped u had a backup. the tar file you restored must of been the one i supplied to u. you could go ba k even further and try a gingerbread rom
 
hmmm im thinking ill just grab the EFS of a friend with the same
phone/service plan?
Maybe that will work?

i dont think flashing back will help.
 
the efs i used (the file u have) was from a different network / carrier to what i had so i dont think that will help either :(
 
baseband is determined by the modem. so maybe try a different modem
 
ah hah! used chainfire triangle away to prepare the phone for the Carrier
and it removed IMEI again.
Now I don't even have the dummy IMEI :p

Gonna leave it like that til i get my friends EFS.
Then ill try flashing modems.
If i dont get it fixed tonight im taking it to the carrier tomorrow
morning.

Ill post back in an hr or so when I get my friends EFS!
 
i flashed up from ICS though!
and I dont have an IMEI anymore!
givin it a shot now anyways...
 
yeah u will need to reflash the imei with ktool
 
so reflash your EFS for an IMEI and then flash the modem?
 
hey man I tried that, tried in Gingerbread too!
Nothing worked.

Im taking it to the carrier tomorrow to get it sorted.

Just wanted to say THANK YOU!!!
 
no worries. sorry i couldn't get it working for you
 
Hi Daniel, i have downloaded the copy of the EFS file you posted but it cannot reflash it in ktool, do i just leave it as a zip on the sdcard or do i have to place it somewhere specific? have tried many methods off xda with no luck. thanks in advance
 
Yes it is, i rooted, and confirmed with root check. i have tried most of the "solutions" on xda to no avail. Initially there was no imei folder within the EFS folder but one of the many items i did try seemed to "place" the imei folder within the efs folder but stil imei showing null/ null. i have tried on stock roms all the way to custom paranoid 4.3. while running Siyah unsecure kernel. Maybe there is something you could suggest i try. Sorry for the delay in response and time differences, live in Zimbabwe :)
 
Hi kyle, my s2 also has the same problem. The first time I faced this problem, I was able to repair it with the solutions shown on the net using ADB. After it worked I immediately took an EFS backup and within a span of two years I faced this problem twice again but I restored EFS from backup and solved the problem in less than a minute and was up and running. Few months back, again I got the same problem but this time the backup could not fix my problem and neither did any of the ADB tricks help so I gave up on it assuming that this is now an hardware issue.
Damien your thoughts? 
 
I believe certain roms (maybe 4.3?) have this problem. I am sure I read it somewhere on XDA.
 
Well in my case I even downgraded to ICS and Gingerbread and tried the restore. No I am using an S3.
 
Hang on. You are using an s3 or s2?
 
Hi Kyle, the zip you need to unzip the 4 files onto the root of the internal storage (not root of system). Then use ktool to restore
 
Hi  Alright i will try it again later as i left the phone at home. but i am pretty sure i did unzip the files to the root of the intternal but will do it again just to confirm. If for some reason it doesnt work could i try the link you sent for S3 on my S2?   
 
Was using an S2 but since I could not fix it, got a new S3
 
Hi +Damien Cole i unzipped the efs zip and its only a 20mb img, is that the right one cause i cant seem to get 4 files
 
Yes using the 20mb img should work
 
Is there anyway to make ktool restore the efs from that img as i have a feeling it is using a different back up. Or do i place the img file somewhere specific as i am placing it in the root of internal storage.
 
If u have a different backup then move that somewhere else. If its successful after restore are you still getting a null imei / baseband?
 
Hello, I have this chinese phone called S4 Spark, it's S4 clone, it can not recognize SIM card. i can see my baseband though, but no IMEI. Service says Radio is off. And, I can not find EFS folder in root explorer. Is there anything I can do? Thanks in advance :)
 
thanks for the file...
Add a comment...